Compilation errors in trunk 68 against Creator 2.8.1

Added by Michael Videlgauz almost 4 years ago

Hello, I have downloaded latest (trunk 68) sources and tried to compile them with Qt Creator 2.8.1
Getting following errors:
S:\Qt\doxygen\doxygenplugin.cpp:256: error: C2039: 'write' : is not a member of 'Core::MessageManager'
S:\Qt\doxygen\doxygenplugin.cpp:296: error: C2039: 'setCodec' : is not a member of 'Utils::SynchronousProcess'
S:\Qt\doxygen\doxygen.cpp:116: error: C2039: 'filePath' : is not a member of 'Core::IDocument'

Is it related to switch to Creator 3.0? Should I also change Creator or use sources from trunk 67 with my current (2.8.1) Creator
My Qt version is 5.1.1

Thank you very much!


Replies (1)

RE: Compilation errors in trunk 68 against Creator 2.8.1 - Added by Andreas Wass almost 4 years ago

Yes r68 trunk is for 3.0.x only. It is not backwards compatible with 2.8.x. For 2.8.x use trunk r67.

(1-1/1)